Print Page | Contact Us | Sign In | Join AAMSE
EDWeb System Requirements
Share |

System Check

A few days prior to the live webinar, please prepare your system by doing a system check:

  • Go to http://livewebcast.net/test
  • Select "Enter as a Guest" and type your name into the box
  • Click "Enter Room" to test your connection and audio
  • If you cannot enter the room, please contact the Help Desk to resolve any issues

General System Requirements

  • Macromedia Flash® player, Version 10.1 or higher
  • Recommended screen resolution 1024 x 768
  • Broadband connection
  • Internet Browser (e.g. Internet Explorer, Firefox, Safari). The use of AOL® is not recommended
  • Cookies enabled in your web browser
  • If using a tablet, it is recommended that you download the Adobe app prior to the date of the webinar

Audio

  • Audio will be heard through your computer speakers; please be sure your computer speakers are on and your volume is up
  • You are encouraged to connect early to ensure ample time to make audio adjustments if necessary
  • For the best audio experience, the use of wired internet (rather than wireless) is recommended

Help Desk

  • Live event help desk is staffed from 8 am to 8pm ET (M-F), as well as one hour prior to start of event through completion.
  • Call 1-888-364-8804 for assistance
  • You can also email support@blueskybroadcast.com.

System-specific Requirements

Windows

  • 1.4GHz Intel® Pentium® 4 or faster processor (or equivalent) for Microsoft® Windows® XP or Windows 7; 2GHz Pentium 4 or faster processor (or equivalent) for Windows Vista®
  • Windows XP, Windows Vista, Windows 7 or Windows  8
  • 512MB of RAM (1GB recommended) for Windows XP or Windows 7; 1GB of RAM (2GB recommended) for Windows Vista
  • Microsoft Internet Explorer 6 or later; Mozilla Firefox; Google Chrome
  • Adobe® Flash® Player 10.1

Mac OS

  • 1.83GHz Intel Core™ Duo or faster processor
  • Mac OS X, 10.5, 10.6 or 10.7.2 (Intel)
  • 512MB of RAM (1GB recommended)
  • Mozilla Firefox; Apple Safari 4 or 5; Google Chrome
  • Adobe Flash Player 10.1

Mobile Download Apps Here

  • Apple devices running iOS 4 or 5; compatible with iPhone 3GS, iPhone 4 and 4 S, iPad, iPad 2, and iPod touch (3rd or 4th generation recommended)
  • AndroidT devices running Android 2.2 or later with Adobe AIR® 2.7 or later for Android; compatible with HTC EVO 4G, HTC Flyer, Motorola Atrix, Motorola Droid X, Motorola Xoom, and Samsung Galaxy Tab (7-inch) and Samsung Galaxy Tab 10.1
  • BlackBerry devices running BlackBerry® Tablet OS (QNX) 1.0.6 or later with AIR 2.7 or later for BlackBerry; compatible with BlackBerry PlayBook